Unreal 4 and Inverted Voxels


#1

Hey everyone,

Just thought I would spread some form of awareness for this.
Me and a good friend are adding voxel support in plugin form to Unreal 4 as well as .QB and .Vox Import options.

We were having a bit of trouble with inverted voxels.

Notice how the text on the back of the TV is inverted?

We were stumped on this for about 30 minutes. In the end it was a export error on my end.

Here is what you need to do -

At the top of the screen go to -

Edit -> Preferences -> Qubilce Binary Export options

Then change Z axis option to Right handed.

Export to Unreal 4

You then should get non inverted voxels.

Hope this helps. :smile:

  • HeadClot

#2

Just as a follow up -

Here is the after picture inside unreal 4.