The file is corrupted


#1

Every time import a image of any extension, when try to save appear the text “duplicated are not allowed” and then can’t open any other file, if try appear the Error " Can’t open “C****”. The file is corrupted.
Ofcourse the files are not corrupted if delete de config or just uninstall and reinstall can open all files again.
This error has been going on for years, some solution? this begins to be overwhelming

Anotation: if try to open a test file appear this:
1 error occured:

  • An uncaught exception occured during the execution of AcnOpenTestFile0 Please report the bug.

    AcnClose
    AcnOpenTestFile0
    AcnNewModel
    CmdCreateModel
    CmdActivate: Model
    AcnFrameWorkarea
    An uncaught exception occured during the execution of AcnOpenTestFile0 Please report the bug

Qubicle v 2.5.8 Home


Corrupted file / duplicate not allowed
#2

i still waiting passed 2 days and no response :frowning:


#3

I didn’t quite understand the problem.
can you provide a step by step explanation like

  1. start qubicle

Sorry you had to wait but I usually don’t work on weekends.


#4

When start the program all works fine, the problem is just when try to import image “i try all extensions and images are about 64x64”.

1: import image from menu import or icon import i try to drag and drop too. The image import correctly.
2: When try to save the file in qbcl format or save as, give this error “Duplicates not allowed”
3: Start slow the program, icons and menus not work, need to close and open again.
4:In the main menu not appear all mi works
5: if try to open any file just give this error (Can’t open
“C****\filename” the file is corrupted) even with the test files included in the program.
6: Need to delete the config files in Documents Qubicle folder to fix that.
7: Can open the files again, except the file with image imported.
8: the file with the image imported is just ruined now is a 1kb file and if try to open give the “corrupted error”, and again with all the files, so need to delete the qubicle document folder again to fix.

So the problem is begin the import image tool, and im really want to use this feature but just i cant if try lost all the work


#5

Any solution or anyone with the same problem?


#6

sorry, but I can’t find a problem.
i followed your steps but everything works fine. no error message
the string “duplicates not allowed” is nowhere to be found in my source code.
I have no idea where that comes from sorry


#7

Im not the only one with this problem this night another user post the same error, but now can’t find this spot is lost in the backup restore i think


#8

sorry about the missing post. I read that one, too.
I don’t know how to help you I am afraid. I can’t fix what’s not broken (on my machine).
can you send me the image you want to import? support[at]minddesk[dot]com


#9

the image i want to import? this error happend with any image with any resoulotion and any extension


#10

I am at a loss then. The thing is, Qubicle itself does not throw a “duplicates not allowed” error. Is this really 100% the error message?


#11

Yes, the error appears whenever going to save any file with an imported image


#12

Here is the image with the error " i dont know if this error is from the program or something with the windows, i try to run qubicle in other computers with win7,and the same results


#13

Ok, so I tried to narrow down the issue. I don’t want to bore you with technical details but this is what I found out:
The string “Duplicates not allowed” is not part of Qubicle’s source code
But I was able to find it in the source code of the SDK I am using to develop qubicle.
The error is only thrown when you try to add an entry to a dictionary (which is a standard datatype) that already exists in that dictionary. So in other words, in order to work properly a dictionary does not allow duplicates.
Ok, so far so good, you might expect that I should be able to locate that dictionary then.
But I can’t. Qubicle itself uses exactly14 of those dictionaries. None of them receives a new entry by calling image import related methods nor by saving files.
So a dictionary must be called outside of Qubicle’s source code and somewhere in the depth of the SDK or in a driver or dll.
My problem is (as mentioned in a previous reply) that I can’t replicate that issue on my computer. If I could, it would be a matter of minutes to fix it. But the point is, nothing like you describe happens on my computer.
I have no idea where to look for that dictionary. It’s like looking for the needle in the haystack.

All I can do is ask questions:

  • when you try to save after importing an image does the save as dialog pop (the one that asks you to enter a filename)?
  • Can you try to save the file as QB instead of QBCL? Does this also cause the error?
  • Have you tried to copy image data to the clipboard and paste it in Qubicle with Edit >Paste OS Clipboard? Does this also cause the error?

#14

Please tell me how to recover corrupted files from https://babasupport.org/apple/iphone-error-4005/ ??? I have uploaded some files and now they are corrupted.