Texturing And UV Mapping - Workflow Suggestions 3DS, Unreal Engine 4


#1

New Qubicle user here. I’m not a stranger to 3D modeling or texture mapping.

My issue is this, like many others that have experienced blurred textures from a single texture atlas being used for a model, I’ve tried different methods to change the compression of the texture when imported into Unreal Engine 4, in addition to importing it into 3DS first to examine the UV maps for myself.

The non-optimized model is frankly, too “heavy” to use in any kind of game engine, especially if you plan on using Qubicle as the primary generator and modeling tool. Its also one of the few ways to get the textures to look correct. There must be a way to improve this.

I’d really love to see what you guys do, because at this point I’m going to have to unwrap the meshes myself and create my OWN UV maps, which is frankly a huge pain in the behind. I’d really love to just use Qubicle —> UE4, but that doesn’t seem to be possible.

I’ve tried to import a non-optimized mesh into 3DS and try to “optimize” it myself, but it requires a lot of tweaking and even then I’m still having to go through and tame stray vertexes that were added or other artifacts. I really like to stay away from Unity since I need lighting and effects that UE4 has.

Anyone work out a good flow for this tool? Its so cool and I really like how it looks in the editor itself, but having to retexture everything is just not what I want to do at this point, I only have so many hours in the day and I’d like to get a project done without having to do everything twice.

Frustrated, but still impressed by Qubicle…


#2

If you set it as a pixel map, it’ll not be blurred in Unreal Engine 4.


#3

Thanks I’ll have to dig into that. Using UE4 Engine v4.15.2 currently. That option must be buried in the texture dialogs, so I’ll go spelunking…

As an aside, 3DS seems to behave properly if the FBX is exported and the texture set in the Material Editor settings for Filtering set to “None”. Amazing how one option changes everything. I thought it was the smoothing groups at first.


#4

Can’t find anything matching “Pixel Map” in UE4 v4.15.2

Just pulling my hair out, lol


#5

Amazingly, I’ve found the combination that allows for crisp texture import from Qubicle --> UE4.

(The below assumes you’ve already imported the .fbx to your level in the editor. This is pretty easy so I’m not spelling it out here.)

In the texture editor for UE4, first open the Sphere-ish example and then look at the lower left hand corner for the source texture map.

Double-click on that, and set the following settings: Compression Settings --> UserInterface2D (RGBA) then change Level of Detail --> Texture Group to 2D Pixels (unfiltered) Save/Apply these changes.

(Edit: You may not need to change the below, I tried it with just the setting above and there were no errors. I might have had an error from something else I was trying to do before… so take the below as optional…)

Now, in the texture editor itself that has the node graph with all the fancy connections, select the Texture Sample node, and you’ll see in the lower left-hand corner some new options. Change Material Expression Texture Base --> Sampler Type --> Linear Color.

If this is set just to Color, there will be an error and it won’t work properly. Save/Apply these changes and rebuild your scene which will recompute lighting and texture changes. There it is!

You may have some lighting issues, where the near perpendicular planes seem darker than the ones facing the sky, but that can be tweaked a bit by adjusting lighting angles and other parameters I haven’t gotten into just yet.

Hope this helps someone…