T-Junctions and edge bleeding


#1

Hi,

I was wondering if there were any updates on this issue, I responded there for an update but I’m not sure if anyone still checks the old forum. http://www.minddesk.com/vanilla/index.php?p=/discussion/1481/exporting-mesh-without-t-junctions#Item_7

Thanks


#2

The missing watertight meshes are now available with FBX (v 2.5.8)


#3

I am using 2.5.8, unfortunately it’s not water tight, unless there is a hidden option to export it with. I can send an example model if you’d like. Here’s the options I’ using

http://imgur.com/YEJSC95

I did also try every other combination to no avail.


#4

http://imgur.com/dlnCw34


#5

The Manifold export option is what is supposed to produce water tight meshes.

Maybe upload some qbcl files and the produced fbx files and say what engine you are rendering in.

Are you using compounds at all?


#6

Sure, here’s a test cube I made.

http://www.filedropper.com/testshape => .qbcl

http://www.filedropper.com/testshape_1 => .fbx

Unity 5.3 but it started happening with Unity 5. As I said before, Qubicle unite with Unity 4 wasn’t showing this problem or at least the Unity renderer didn’t render it. The old models I used in Unity 4 with qubicle unite, used to render without a problem. To test it out I imported the old models into Unity 5, they also have the same problem so something in the new engine is causing it to be visible.

No compounds.


Floating vertices, optimization problems
#7

Hm I see now, setting the light’s Normal Bias to 0 makes the problem go away. But of course this means that Soft shadows are not usable in the game. Because the terrain gets jagged shadows with 0 normal bias. Hard shadows doesn’t have this problem.

http://www.filedropper.com/showdownload.php/normalbiasupped

http://www.filedropper.com/normalbiasdown


#8

It seems to be an issue with the UVs generated / imported that is causing the bleeding on shadow casting which is still causing problems in some situations? There was a change from Unity 4 to Unity 5 with how this works.

Try to set cast shadows in your mesh renderer component to two sided. Then the Shadow Bias to 0.04 and Normal Bias 0.05.

Maybe try to post in Unity forum about this too. It’s not necessarily a Qubicle issue.


#9

Perhaps.

Your hack works though, aside from minor issues it’s usable. Thanks.