My Model Displays White Dot in Unity


#1

Hi, I’m new to Qubicle. I created a car model in Unity and found the shadow was weird. There was some white dots in the shadow. I was not sure if it was the Unity problem or the model problem. Any ideas are welcome. Thanks!


#2

You will want to mess around with the shadow bias (I forget the actual name. its one of the few shadow sliders on your unity model) on your directional light!
I had to do that in my scene and then it looks better! Its one of those things where you need to tweak your settings to get everything looking right. Setting it to the lowest introduces other weird shadows on planes


#3

Dunfee is correct; you need to adjust the Bias and Normal Bias settings for the shadow-casting light source. These settings affect the edge detection, if you will, for casting shadows. The hard corners of voxel models do not do well with the default bias and normal bias settings. Adjust them until you get a result you like.