Mesh optimization help


#1

Whenever I select mesh optimization, the exported model becomes blurry.
Thr colors blur into each other and the models look ugly.
Although when I turn the mesh optimization off, the models are fully and properly rendered.

Is there a way to optimize meshes without the different colors blurring into each other?

What setting/options should I tweak?


#2

@joyDivided13 This is a very easy fix, you can put on the mesh optimization, but remember the main step comes after you import it into your main 3d rendering program (ex: Blender). So to fix the texture blurry problem, you need to turn off the texture filtering that the software does. The texture filtering allows from antialiasing which causes that blur effect on the pixelated textures.

So look in your material/texture setting to turn off the texture filtering off. So when you go to render it, it will work.

However, in the viewport, the texture will still look blurry. So the texture only becomes pixelated when actually go to render.