How can I modify the Vox Number of colors


#1

I am using the voxelizer to voxeliz a 3d model and since it has many colors (not a simple model) it produces many colors, when I try to export as .vox I get this error.

  • AcnExportVoxlapVox Number of colors used exceeds maximum of 254. Export halted.

How can I reduce the number of colors?

Edit: I tried opening the texture png in photoshop and save it as 256 color dither png. Still got the same error.


#2

I can’t run Qubicle ATM, so pardon my imprecise instruction :slight_smile: Hope my memory serves well…

Load up model in Qubicle, select its matrix. Go to Colours category in top bar. Look for option that import all colours used by model to Qubicle palette. It will ask if you want to remove all existing palette swatches, confirm. You should now have models palette loaded into Qubicle. Now remove by hand i.e. 8-12 swatches of tones that are common in whole palette so they wont be missed after colour reduction. Go back to top ‘Colours’ menu and apply palette on selected matrix. It will reduce models colour set to just colours from Qubicle palette. Export and see if it worked for You.

If it won’t, use this tool:


With this extension you will get GUI if You are Windows user:

Documentation covers topic of colour reduction and various other super useful voxel related stuff.

Cheers