[FIXED] Violation, Double Window Color Picker, Pivot and Renaming Bug?


#1

Hi there! I keep getting on this error while changing the pivot point and renaming my voxels,

I tried restarting it was gone, then decided to change the pivot again then I encountered this one.

1 error occurred:

  • An uncaught exception occurred during the execution of AcnEditPivotPosition Please report the bug.

AcnEditPivotPosition 0.833333253860474 428.666625976563 853.333251953125
CmdTranslateExportPivot: 0.833333253860474 428.666625976563 853.333251953125 absolute
AcnEditPivotPosition 0.833333253860474 428.666625976563 853.333251953125
CmdTranslateExportPivot: 0.833333253860474 428.666625976563 853.333251953125 absolute
AcnEditPivotPosition 0.833333253860474 428.666625976563 853.333251953125
CmdTranslateExportPivot: 0.833333253860474 428.666625976563 853.333251953125 absolute
AcnEditPivotPosition 0 428.666625976563 853.333251953125
CmdTranslateExportPivot: 0 428.666625976563 853.333251953125 absolute
AcnEditPivotPosition 0 0 853.333251953125
CmdTranslateExportPivot: 0 0 853.333251953125 absolute
AcnEditPivotPosition 0 0 0
CmdTranslateExportPivot: 0 0 0 absolute
An uncaught exception occurred during the execution of AcnEditPivotPosition Please report the bug.

BUT after encountering it, the pivot still changed it’s just weird that the software is getting that error

also I’m getting a repeating color picker window every time I pick or change my own colors. Which is really weird, you have to color pick again on the second window or cancel the second window.

I’m using, Qubicle 3.0.4 Indie Edition :smiley:
OSX El Capitan 10.11.5


#2

Hey there, thanks for the report.
I tried to figure out the pivot issue but wasn’t able to locate the bug.
Does this always happen? If so can you show me a way to replicate it?

What I do:

  1. Start Qubicle
  2. Open testmodel “Deer”
  3. Select Deer
  4. Use Modify > Piviot > Position
  5. Change all values to 0 0 0
  6. Click ok

Works fine.
You mentioned something about “renaming my voxels”, though. Is that part of the bug?

And about your color picker problem: the color picker only pops up if you double click a swatch. If you single click a swatch then it’s picked as foreground color. Use dbl-click to modify a swatch


#3

hi there! thanks for testing it out, here! I uploaded a screen record that I’m experiencing everytime (RENAME and Double Window Color Picker) :slight_smile: the PIVOT one sometimes it’s fixed sometimes not, I’ll try to reproduce it again see what triggers the problem :slight_smile:


#4

Hey, thanks for the video. I tried to replicate the bug on OSX and on Windows doing exactly as you did… but, no issue at all.
The bug is quite clearly there on your mac, though.
So, when you click the ok button the first time, the value changes back to the original and when you click ok the second time the window closes but an exception is raised.
Looks like you have to click ok on the color picker twice, too. Is that true for all dialogs?
That’s really strange… I honestly don’t know what happens at the moment.
At first I thought it may be an OSX issue (I work on windows and don’t test as much on osx as on windows), but the osx version on my machines work fine, too.

or, do you get two windows instead of one? i am confused…

now, on a closer look I notice that you double click the name field… does a single click not work?


#5

Hey, thanks for the video. I tried to replicate the bug on OSX and on Windows doing exactly as you did… but, no issue at all.
The bug is quite clearly there on your mac, though.

Yeah probably my mac or I’m doing something not right, It’s okay the important things is it still works even though there’s a notification of error.

So, when you click the ok button the first time, the value changes back to the original and when you click ok the second time the window closes but an exception is raised.
Looks like you have to click ok on the color picker twice, too. Is that true for all dialogs?

Yeah the value changes back to original, but it’s already applied in the main screen, it’s just a bit confusing I guess you have to just get used to it. worried:

That’s really strange… I honestly don’t know what happens at the moment.
At first I thought it may be an OSX issue (I work on windows and don’t test as much on osx as on windows), but the osx version on my machines work fine, too.

or, do you get two windows instead of one? i am confused…

I’m only using Mac OSX El Capitan version: 10.11.5 :slight_smile:

now, on a closer look I notice that you double click the name field… does a single click not work?

Not that you mention it, I guess SINGLE CLICKING them all works fine! lol! :grinning: even the color picker!
Thanks for the help! I guess I should avoid double clicking everything, Anyways! More power to this software! I’ll be waiting for the exciting future updates :slight_smile:


#6

Oh ok, I am glad that could be resolved!
Though, to be honest, that double click should not pass through. This error should never occur. I am not sure why that happens. I run El Capitan, too, so that can’t be the issue.
Needs some more investigation.
Anyhow, have fun!