Exporting with centered origin to UE4


#1

Hey there!

Fantastic, can only put one image in as a new user… remove the space between h & ttp in the imgur links for them sweet visual aids

I’m having issues exporting my qubicle objects with a centered origin. When exporting objects from an environmental atlas the object origins aren’t centered despite pivot options being centered. Instead they show up with a corner origin when imported to UE4.

Corner Origin

The only way I can get an objects origin centered is by using the Align tool and then aligning X/Y/Z axis centers to the parent Workarea.

Workaround
http://imgur.com/KnP4MTj

From there, exporting the object with these settings

Export Settings

Resulting in what I need

Center Origin

As you can see however, this makes bulk exporting objects from an environment atlas extremely tedious.

Is there a way I’m not seeing to achieve what I want? The closest option I found was by creating a compound and exporting within it provides a World Origin option which doesn’t seem to do anything:

Random World Origin Option

Thanks in advance! -


#2

I am not a UE user (never opened it). In Unity there’s a local pivot option that you have to enable to see and use the pivot set in Qubicle. I expect something similar to be in UE


Pivot points not exported
#3

Sadly no option in UE4:

"UE4 will not respect the local axis that was from any modeling program. The pivot is overwritten by the world origin. This is why it’s recommended when exporting your mesh from Max or any other modeling software where you want the meshes pivot to be at the world origin (0,0,0).

This feature has been requested and for using the pivot from the modeling program vs one that is created on import, but that there is no timeline for when/if this would be added." - https://answers.unrealengine.com/questions/164234/how-to-use-a-local-axis-on-an-imported-mesh.html

Which sucks for a lot of reasons.


#4

Did you try OBJ instead? Since OBJ does not support pivots I recalculate the vertex positions to achieve a similar effect.


#5

.FBX is ideal for UE, as the engine has useful features with its fbx content pipeline. Won’t matter with most of my objects as they’re primarily static.

Just gave .obj it a whirl. seems to put the object on its side with the origin set on the center of its side.

  • importing directly from qubicle with preserve positions unchecked.

I’ll fiddle around with it tomorrow when I’m working again. Maybe there’s a UE plugin out there that I can find :wink:


#6

I’ve definitely had my struggles with UE4.

Here’s a post i made on my blog for setting up assets for UE

http://zsinked.com/blog/6139291716793925645

hope this sheds some light? same to you Admin


#7

Read through it y2bcrazy, confirms my suspicions:

It turns out that the pivot location within Unreal 4 is completely different to Qubicle 2.0, both in its orientation and value.

Not only did i have to rotate the model in Qubicle but i had to relocate the pivot point on the model

Sounds about right. :confused:

I’ve kind of managed to get a somewhat usable result by flipping my qubicle scene and rotating it 90 degrees. Then when importing to UE4 setting the Roll to 180.

Origin is now at the bottom center, which is easier to work with at least. Still not center center though.
Not sure what is more tedious at this point, aligning all objects in qubicle to center center or flipping/rotating my whole scene.

I’ll say if I work out anything better throughout the day. Thanks fellas.


#8

awesome, well im glad that that post managed to help you to some capacity. I think arranging it in Qubicle prior to importing in Unreal is a lot more feasible and simple.

Make the level as per usual > once done layout and level design you compound the entire thing > flip along Y axis 90 degrees > uncompound > adjust pivots on objects > export.

Personally, the less work you have to do in-engine for your game, the better.


#9

yeah exactly, bottom center will work with procedural walls and floors for level building at least. Any characters or moving objects I’ll set up in their own qubicle files so the origin wont be a problem. Cheers mate.


#10

Here’s some poorly made gifs for anyone importing qubicle to Unreal Engine 4 in the future.

Select all objects in the scene, flip vertical and rotate X 90 degrees.
http://imgur.com/8imEZ04

Export as OBJ, un-checking preserve positions
http://imgur.com/l8QmH4a

Import to UE4, changing the Roll to 180. (change scale here if necessary)
http://imgur.com/yXi9kBP

Optimize the texture (so it’s not blurry) Change the compression settings to User Interface and the Texture filter to Nearest.
http://imgur.com/Lkds3Xg


#11

If someone can outline the problem and what I need to change I’ll add it to the list. The export pipeline will be a big task again this year. I haven’t prioritized new features this year though. Steam first.


#12

Sure thing Admin,

The issue is mainly a UE4 thing. As the origins seem to be different in UE4 compared to qubicle but anyways:

The Problem: Objects exported as FBX from qubicle have their origins (pivot points) set to the corner of the object as shown:

I’m guessing this is because you set the position to 0,0,0. of a selected object when preserve positions is unchecked.

Maybe Solution: If it is possible to have an option to align the x,y,z centers to 0,0,0 with one click instead (The same thing is achieved with the align tool; setting xys axis to center and aligning to parent work area); that would be nice to have in the exporting options.

The stuff with OBJ in the previous post is just the work around for mass exporting to UE4 at the moment. It’s an OK solution, but overall this issue probably isn’t that high of a priority as most users are probably using Unity.


#13

We getting this issue resolved soon? Can you make export settings for each engine?

It’s getting to be a pain manually fixing these in engine.


#14

TBH, the rotation is fine. I just tested it out with all export options, placing my test object in the corner of the “origin” 0,0,0, resulted it being fine rotation wise. Not pivot wise, For tiles, this is fine, you can set Position to World Origin and it will import at the corner.

Pivot location had no effect whatsoever, really. “as specified?” where can we specify this?


#15

I just don’t get why Pivot Option Centered does not make my pivot point center on FBX export :frowning:


#16

Sorry to resurrect a topic, but I get a similar issue with assets imported into Godot. And a quick test says it happens in Unity as well. If I choose “As specified” for the position the pivot seem to be place where the world center was, and if I choose “World Origin” the pivot is centered on the front plane of the obj instead of the bottom as set in cubicle. Why is there no Pivot setting in OBJ export, seems UE4, Godot and Unity all support this? I am finding the dae has the correct pivot, but Godot seem to fail to automatically use the material, (just my luck).


#17

To expand on the above, if I directly edit the DAE file and remove the “file:///” from the reference to the texture and re-import into Godot, the materials load as expected. I imagine this is a bug in Godot, though I’m not an expert by any means, just thought it could help someone if I shared.

Now I just need a batch method of applying this fix for now.