Colours changing after Unity Import


After scanning through the forums, I couldn’t find this issue to have been raised by anyone else so I suppose its my own unfamiliarity with Unity that is letting me down.

I’ve imported some FBX models into Unity (2018.3.8) and it maps the textures correctly but the colours themselves have changed from what is displayed inside of Qubicle as can be seen below:


I didn’t want any edge bleed so set this to 0, but this was the only change I’ve made from other models I’ve imported. Can anyone let me know what I’ve got to set/change to fix this?


That’s very strange never seen that happen before.

Here are the only things I could think of that would’ve caused these issues:

  1. You by accidentally changed the colors (HSV) and forgot before your export.
  2. The lighting/shader in the Unity game engine is causing the model to look brighter.
  3. Try exporting as OBJ into Unity.
  4. Try importing the model with another 3D programme such as Blender, and if the issue is consistent.

I would try looking in the to find more info on exporting.

If nothing else works, contact:


I would lean towards the lighting shader in Unity as its not the only model affected. Though it also doesn’t affect all the models… Very strange.

As for exporting as OBJ into Unity: I can’t seem to figure out how to get the texture map to apply to a model in OBJ format once imported. I copy everything across but it just won’t find the texture file. I’ve followed YouTube videos and scoured the Unity forums but can’t seem to get OBJ files to ever apply a texture :confused:


I’ve figured out the OBJ export. The models seem fine with OBJ format. I’m a bit worried however as I was lead to believe that FBX models were the only choice for animation. If this is the case, I could still end up hitting the same issue… Has anyone got any ideas on this?



When you export there should be a separate folder along with the 3d model called “materials”. In that folder, there should be a texture file.

So I think I may know why the colors look different, Qubicle has a default shader that comes along with the model. This shader gives it a cartoony feel. I always delete the shader and make separate diffuse shader using the texture from the aforementioned materials file.

Also, FBX is the standard for animations, so that might help.


Hey @Zeitheus

Thank you for your help thus far. It turns out OBJ files do have an issue as for some reason the export brings through voxels that are purple instead of brown… My first thought is this could be the colour palette though with the OBJ export you can’t choose which one the file uses.


So I will try the shader deletion. Erm, how would I go about deleting the default shader and making a diffuse shader?

And since FBX is the standard, surely it would be better to stick with one file format for all models and not swap between them? I’m sorry for all the questions, quite new to modelling.



I’m not sure why there would be a color effect to your texture, unless from what I’ve previously stated:

  • The shader is doing something strange (delete it).
  • The lighting in your scene is affecting the color, ex: the sunlight or world/HDRi light.

Since I am not a Unity user I am not sure how to delete the shader.

When it comes to file formats, sticking to one for consistency is what I try to do (unless the file needs a specific format).


So a bit of an update:

I don’t think it is the lighting within Unity and I have no idea how to delete/edit/create my own shader to compensate. The reasoning behind this thought is, the same model brought through from MagicaVoxel (model on right) is fine with no colour distortion whatsoever.


This is frustrating as I wanted to step away from MagicaVoxel moving forward but it would seem I can’t :confused:



I honestly don’t know why that would occur. I really do not think Quibcle should be the one to blame since the texture error doesn’t make sense since Qubicle from experience and others have not had any issues when import to other software. I used Maya, Blender, Unity, and Unreal and never had an issue like that. I think you should try a Unity forum our subreddit and ask if they have a solution.


Not blaming Qubicle, merely pointing out that it’s frustrating.

I haven’t had any time over the weekend to test anything but hopefully will find a solution either through my own experimentation or by locating the Reddit group/Unity Forum.


Just to bring this thread to a close, I spent the weekend trawling through YouTube and asking Reddit for help on this.

Turns out it was simply a combination of the default shader used in Unity (the Unlit Texture default shader works the best at replicating the vibrant voxel colours) and the compression that is automatically applied to the texture. Setting this to None removed the purple and then the shader was just to bring the colours from a washed sort of look.

Thank you @Zeitheus for pitching in!