Blurred texture when imported into Unity


#1

I created a model in Qubicle and exported it as a Collada DAE. It looks fine in Qubicle, but in Unity, the texture appears extremely blurred.

Screenshot in Qubicle:

Screenshot in Unity:


#2

What you’re seeing is AA(Anti-aliasing)

AA is quite a nice thing, but doesn’t work with voxels in a way that is beneficial. Just find your voxel models texture in unity. Select it and look at the inspector. You should see texture options. Basically just set the filter mode to point and you’ll be done. I also recommend you use truecolour format.

Do this for all imported voxel textures.

Here is a picture of how I set my textures up for voxels.


#3

Thank you, this worked perfectly! :slight_smile:


#4

After applying the same settings shown in your screenshot, it looked fine so I continued working on my game in Unity. Today, I was testing the game on my phone (using Unity’s “Build and run” feature) and the texture appeared blurred again (but not the same type of blur as I previously had. The texture looks fine in the Unity editor though.

Unity editor screenshot:

Screenshot from my phone after building and running the game:


#5

Check if your mobile texture format is 16bit not compressed


#6

Hi,
Did you get a solution for this? I have also been having a problem of lower resolution when it was imported into Unity3D. I would like to ask you to share how you made a breakthrough if you did. Thank you.


#7

Yes, so all I had to do was go to the textures and set “Filter Mode” to “Point (no filter)” http://i.imgur.com/ESDmwFE.png


#8

Thank you so much! I will try that!