Any tips and tricks for working with Qubicle 2.5? (Extruding)


#1

I just upgraded to Qubicle 2.5 and like many of the improvements (ghosting == GREAT!), but am also having trouble adjusting to the new flow. Any tips for how to get back up to speed quickly would be great. These are the issues I’m having so far:

  • I really miss CMD + Arrow Key to extrude selected voxels. I learned about it from one of the old tutorials and used that functionality all the time. Is there an alternative for extruding with key controls, or was this functionality removed?
  • I am having a lot of trouble with the Pencil, Add Voxel and Paintbrush tools. These tools don’t seem to work the same way they used to. Right now, I’m trying to draw some voxels on the wall of the Matrix and can’t seem to get it to work. I’ve tried picking the Auto slice mode and making sure “Draw on Walls” was selected, but nothing…
  • Any tips for working with Extrude? I select a voxel, drag and hold to select a box and then… ? I let go and occasionally I get some voxels, but most of the time I don’t. I am stumped.

Not sure if this makes a difference, but I’m using the Mac version of Qubicle 2.5.

Thanks!!


#2

The Pencil Tool can add voxels to floors / walls of a matrix. You can use the Add Voxel Tool to add additional voxels on. I noticed if your “camera” is below the “floor” of a matrix then drawing onto walls no longer works so check your rotation of the matrix - seems like a bug if you change the camera box to “bottom” it’s the only view that can’t draw on open space with Pencil Tool.

I would like extrude to add the ability to hold shift to add to the selection.


#3

extruding wasn’t removed. If you are using the new alternative mode then Alt + arrow keys is the shortcut. I did this because I assumed that Photoshop is acting the same way. If it doesn’t then I’ll change it back. I don’t use OS X very much

You very likely have something selected. Make sure that nothing is selected or uncheck “Mask” in the tool options

Extrude is a 2 click tool. First click and drag a base then release and drag the height, click a second time to confirm


#4

Yes! So glad to see that extrude with keyboard still works. I don’t use Photoshop that much (more of an Illustrator user), so I’m not sure if Alt is more or less intuitive to Photoshop users. Just glad to see that it’s still there. Probably no need to change it for Mac users, but it would be nice if it were on a list of keyboard shortcuts (maybe it is and I haven’t found it yet?).

Unchecking the mask box was the issue with using the Pencil tool. It’s cool that feature is there. I definitely see why this would be helpful, but didn’t get that was my issue at first glance.

I’ll have to keep messing around with the Extrude with the mouse tool. I still get mixed results when I’m working with an object with a depth of 1. Thanks for clarifying that it’s a two-click tool though.